Publicidad

Los requisitos de Google Play para 2019: aplicaciones optimizadas para Android Pie y nueva advertencia de seguridad

Los requisitos de Google Play para 2019: aplicaciones optimizadas para Android Pie y nueva advertencia de seguridad
1 comentario

Publicidad

Publicidad

El pasado año Google puso en marcha su plan para mejorar la seguridad y rendimiento de Android exigiendo que los desarrolladores optimicen sus aplicaciones al menos a la penúltima versión de su sistema operativo. Es por ello que desde noviembre del año pasado todas las nuevas aplicaciones y actualizaciones que lleguen a través de Google Play tienen que estar optimizadas para Android Oreo.

Pues bien, ahora el equipo de Google Play da detalles sobre los plazos y nuevos requisitos para 2019. Este año también habrá requisitos para otras tiendas de aplicaciones y nueva advertencia de seguridad para aplicaciones de versiones antiguas.

Requisitos de Google Play para 2019

Comenzamos por los plazos y requisitos de la propia tienda Google Play Store. Para ofrecer la mejor seguridad y experiencia de usuario para finales de 2019 la tienda no aceptará aplicaciones y actualizaciones que no estén optimizadas al menos para Android 9 Pie. Para esas fechas ya estará en el mercado Android 10 Q. Los plazos son los siguientes:

  • Agosto de 2019: las nuevas aplicaciones tendrán que estar optimizadas a Android 9 (API 28) o superior.
  • Noviembre de 2019: las actualizaciones de las aplicaciones existentes tendrán que estar optimizadas a Android 9 (API 28) o superior.

Como el año pasado, las aplicaciones existentes que no reciban actualizaciones no se verán afectadas y pueden seguir descargándose desde Play Store.

Aplicaciones distribuidas a través de otras tiendas.

Google quiere que las aplicaciones descargas por los usuarios estén optimizadas para las versiones más recientes de Android, independientemente de dónde sean descargas. Es por ello que a partir de este año las tiendas de aplicaciones de Huawei, OPPO, Vivo, Xiaomi, Baidu, Alibaba y Tencent requerirán que las aplicaciones apunten a la API 26 (Android 8.0) o superior.

Nueva advertencia de Google Play Protect

Google ha detectado que más del 95% del software espía que se distribuye fuera de Play Store usa la API 22 (Android 5.1 Lollipop) o inferior para evitar los permisos de tiempo de ejecución. Para evitar la instalación de aplicaciones de versiones muy antiguas del sistema operativo, Google Play Protect avisará a los usuarios cuando intenten instalar un APK que tenga una API antigua. Los plazos para el despliegue de esta novedad son:

  • Agosto de 2019: las nuevas aplicaciones recibirán advertencias durante la instalación si no se usan la API 26 (Android Oreo) o superior. Si tenemos las opciones para desarrolladores activadas veremos la advertencia antes de agosto.
  • Noviembre de 2019: las nuevas versiones de las aplicaciones existentes recibirán advertencias durante la instalación si no usan la API 26 (Android Oreo) o superior.
  • 2020 en adelante: el requisito de nivel de API avanzará anualmente.

En versiones antiguas de Android, Google Play Protect mostrará esta advertencia si intentamos instalar una aplicación optimizada para una versión anterior a la de nuestro sistema operativo. Por ejemplo, en Android 6.0 Marshmallow (API 23) nos mostrará la advertencia si intentamos instalar una aplicación optimizada para la API 22 o inferior, o en Android 8.0 Oreo (API 26) si intentamos instalar una aplicación optimizada para la API 25 o inferior.

Vía | Android Developers

Temas

Publicidad

Comentarios cerrados

Publicidad

Publicidad

Inicio
Compartir