Compartir
Publicidad

Android P se queja si abres una app para Android 4.1 o inferior

Android P se queja si abres una app para Android 4.1 o inferior
4 Comentarios
Publicidad
Publicidad

Con Android P Google está sembrando los cimientos de Android moderno, y parte de esta modernización implica empezar a soltar lastre en temas de compatibilidad. Con la Developer Preview podemos ver el primer paso: Android muestra un aviso cuando intentas instalar una aplicación demasiado antigua.

Hemos probado dicho aviso con el APK de Bootlog Uptime (una aplicación de 2013 diseñada para Android 1.6 Donut y el resultado es una ventana emergente de aviso instándote a que actualices la aplicación o te pongas en contacto con el desarrollador.

Por ahora aviso sin bloqueo

Aviso

Aunque la documentación de Android decía que Android P avisaría a los usuarios antes de instalar aplicaciones destinadas a un SDK inferior a Android 4.2, lo cierto es que en nuestras pruebas el aviso no aparece al instalar, sino al abrir la aplicación. El texto lo puedes leer en la captura de pantalla anterior: se limita a decir que la aplicación podría no funcionar.

Por lo demás, la aplicación sigue funcionando sin problemas una vez pulsas Aceptar y el aviso solo aparece una vez por cada instalación de una aplicación, así que por ahora no deberías preocuparte demasiado. Todavía podrás usar aplicaciones antiguas.

Sin embargo, en un futuro Google tiene planeado ir cerrando el cerco hasta lograr que desarrolladores y sistema operativo vayan más a la par. Este aviso de Android P es un primer paso que sin duda acabará terminando en medidas más graves como el bloqueo completo. Este mismo año, las aplicaciones nuevas y actualizaciones enviadas a Google Play deberán ser creadas con el SDK de Oreo como base.

Es preciso recordar la diferencia entre el SDK de destino (o target SDK) y el SDK mínimo. Una aplicación puede ser compatible con Lollipop y Marshmallow pero estar creada con el SDK de destino de Oreo. El cambio es solo en la parte del desarrollador, que debe acomodar la aplicación a las últimas prácticas y cambios en el sistema operativo, que es lo que persigue Google.

Vía | Android Police
En Xataka Android | Descubre qué versiones antiguas de las aplicaciones de Google no funcionarán a partir del 3 de abril

Temas
Publicidad
Publicidad
Publicidad
Inicio
Inicio

Ver más artículos